www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Ho <alex...@wcom.com>
Subject mod_jserv/5611: servlet zone not found problem
Date Thu, 20 Jan 2000 20:07:50 GMT

>Number:         5611
>Category:       mod_jserv
>Synopsis:       servlet zone not found problem
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    jserv
>State:          open
>Class:          support
>Submitter-Id:   apache
>Arrival-Date:   Thu Jan 20 12:10:00 PST 2000
>Closed-Date:
>Last-Modified:
>Originator:     alex.ho@wcom.com
>Release:        1.3.9
>Organization:
apache
>Environment:
NT4.0, sp4, jdk1.2.2, jsdk2.1, Jserv1.1b3
>Description:
I installed both Apache and JServ, then verified using the servlet IsItWorking in the servlet
directory without any problems.  But, when I tried to add new zones, it keeps complaining,
saying something like servlet zone "myzone" not found in the mod_jserv.log.  No zone was working
for me except for the zone "root".

Here are the only changes I made to the config/property files, following all directions in
the doc:

1. in jerv.conf, added "ApJServMount /myservlets  /root1"
2. in jserv.properties, changed "zones=root" to "zones=root,root1"
3. in jserv.properties, added line
	"root1.properties=C:\Program Files\Apache JServ
1.1b3\servlets\zone.properties"
	which is pointing to the same place where root.properties is.

Entering http://127.0.0.1/servlets/IsItWorking is ok.  But, entering
http://127.0.0.1/myservlets/IsItWorking returns me an error of servlet zone
"root1" not found in mod_jserv.log.

Any info in greatly appreciated. If you don't mind sending me your jerv conf
and property file with zones that are working.



>How-To-Repeat:

>Fix:
Send me config/properties files with zones working.
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message