www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From LE BRAY Daniel <leb...@iut.univ-lehavre.fr>
Subject other/5599: Apache start then exit (because of a memory address error msg - under gdb)
Date Mon, 17 Jan 2000 11:37:43 GMT

>Number:         5599
>Category:       other
>Synopsis:       Apache start then exit (because of a memory address error msg - under
gdb)
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon Jan 17 03:40:00 PST 2000
>Closed-Date:
>Last-Modified:
>Originator:     lebray@iut.univ-lehavre.fr
>Release:        1.3.9
>Organization:
apache
>Environment:
(RedHat 5.2) GNU/Linux 2.0.36 i686/233. Compiler: GCC 2.7.2.3.
PHP 3.0.12
>Description:
After compiling Apache (./configure --prefix=/opt/www --enable-shared=max)
all is ok. Then we compile PHP (./configure --prefix=/home/www/php3 \
--with-apxs=/home/www/bin/apxs \
--with-config-file-path=/home/www). All seems OK. We launch Apache... ok
All is fine... until we stop it and re-launch'it. Apache don't start.
Under GDB, we get:
# gdb /opt/www/bin/httpd  
GNU gdb 4.17.0.4 with Linux/x86 hardware watchpoint and FPU support 
Copyright 1998 Free Software Foundation, Inc. 
...
This GDB was configured as "i386-redhat-linux"... 
(gdb) run -X -f /opt/www/conf/httpd.conf 
Starting program: /opt/www/bin/httpd -X -f /opt/www/conf/httpd.conf 
Cannot access memory at address 0x4024d5a0.
(gdb) step 
Cannot access memory at address 0x4024d5a0.
(gdb) bt 
#0  0x40005dd1 in _dl_debug_state () at dl-debug.c:55 
#1  0x400e361c in _dl_close (map=0x80b35b0) at dl-close.c:141 
#2  0x40055a84 in doit () at dlclose.c:28 
#3  0x40005bc0 in _dl_catch_error (errstring=0x40057424, operate=0xbffffc78) 
at dl-error.c:105 
#4  0x40055dd5 in _dlerror_run (operate=0xbffffc78) at dlerror.c:69 
#5  0x40055ad5 in dlclose (handle=0x80b35b0) at dlclose.c:31 
#6  0x806e808 in ap_os_dso_unload () 
#7  0x804ebde in unload_module () 
#8  0x805094a in run_cleanups () 
#9  0x804f1a0 in ap_clear_pool () 
#10 0x805ebb7 in standalone_main () 
#11 0x805f51f in main ()

So, i have no idea what the hell is going on...
>How-To-Repeat:
Sorry, we don't have public access.
>Fix:
We tried 3 times with 2 different systems and we get the same results.
I have no idea about it...
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message