www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David C.Todd <hack...@hacksaw.org>
Subject config/5581: Virtual hosts never work at all, you only get the main page.
Date Thu, 13 Jan 2000 16:49:18 GMT

>Number:         5581
>Category:       config
>Synopsis:       Virtual hosts never work at all, you only get the main page.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Jan 13 08:50:01 PST 2000
>Closed-Date:
>Last-Modified:
>Originator:     hacksaw@hacksaw.org
>Release:        1.3.9
>Organization:
apache
>Environment:
Linux 2.2.13 RedHat 6.1 Apache 1.3.9 from RedHat rpm
>Description:
I have 1 A name and 2 CNAME's for my box. Internally the box is named as a node in a subdomain
from one of the CNAME's.
(habitrail.home.fools-errant.com)
Note that www.fools-errant.com actually resolves someplace else. However, removing that virtual
host and restarting changed nothing.

I set up name virtual hosts in the config file. The config file is the vanilla file supplied
by RedHat, I added:

NameVirtualHost 216.41.5.170

<VirtualHost 216.41.5.170>
ServerAdmin webmaster@www.hacksaw.org
DocumentRoot /home/httpd/html/hacksaw
ServerName hacksaw.org
ServerAlias *.hacksaw.org
ErrorLog logs/error-log.hacksaw.org
TransferLog logs/access-log.hacksaw.org
</VirtualHost>

<VirtualHost 216.41.5.170>
ServerAdmin webmaster@www.privatecircus.com
DocumentRoot /home/httpd/html/privatecircus
ServerName privatecircus.com
ServerAlias *.privatecircus.org
ErrorLog logs/error-log.privatecircus.org
TransferLog logs/access-log.privatecircus.org
</VirtualHost>

<VirtualHost 216.41.5.170>
ServerAdmin webmaster@www.fools-errant.com
DocumentRoot /home/httpd/html/fools-errant
ServerName fools-errant.com
ServerAlias *.fools-errant.com
ErrorLog logs/error-log.fools-errant.com
TransferLog logs/access-log.fools-errant.com
</VirtualHost>


I have only the one httpd.conf. The output from the -S option

habitrail:/etc/httpd/conf
hacksaw > httpd -S
VirtualHost configuration:
216.41.5.170:80        is a NameVirtualHost
                       default server hacksaw.org (/etc/httpd/conf/httpd.conf:342)
                       port 80 namevhost hacksaw.org (/etc/httpd/conf/httpd.conf:342)
                       port 80 namevhost privatecircus.com (/etc/httpd/conf/httpd.conf:351)
                       port 80 namevhost fools-errant.com (/etc/httpd/conf/httpd.conf:360)

The browser I am checking it with is Netscape 4.7 and lynx 2.8.1rel.2. The lynx is running
on a host on a different network.

Running strace on the httpd -X run reveals the browser is send a well formed Host: header,
(i.e. "Host: www.hacksaw.org")

My net connection is an SDSL line, with the router doing NAT. No one else is running a web
server on my network, I'm running just apache on one box.
>How-To-Repeat:
www.hacksaw.org
www.privatecircus.com
>Fix:
NONE
>Release-Note:
>Audit-Trail:
>Unformatted:
 [In order for any reply to be added to the PR database, you need]
 [to include <apbugs@Apache.Org> in the Cc line and make sure the]
 [subject line starts with the report component and number, with ]
 [or without any 'Re:' prefixes (such as "general/1098:" or      ]
 ["Re: general/1098:").  If the subject doesn't match this       ]
 [pattern, your message will be misfiled and ignored.  The       ]
 ["apbugs" address is not added to the Cc line of messages from  ]
 [the database automatically because of the potential for mail   ]
 [loops.  If you do not include this Cc, your reply may be ig-   ]
 [nored unless you are responding to an explicit request from a  ]
 [developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]
 
 


Mime
View raw message