www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Walter Klomp <wal...@swiftech.net.sg>
Subject os-linux/5123: Configure completes only ONCE, second time fails...
Date Mon, 11 Oct 1999 10:05:39 GMT

>Number:         5123
>Category:       os-linux
>Synopsis:       Configure completes only ONCE, second time fails...
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon Oct 11 03:10:01 PDT 1999
>Last-Modified:
>Originator:     walter@swiftech.net.sg
>Organization:
apache
>Release:        1.3.9 (with or without SSL)
>Environment:
Linux blackbox 2.2.12-20smp #1 SMP Mon Sep 27 10:34:45 EDT 1999 i686 unknown

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)
>Description:

This used to work on my RedHat 6.0 installation. I now upgraded to a new box with RedHat 6.1,
funnily enough with the same compiler, but the configure script doesn't work... The rest,
like MySql, and PHP3 compiles great... The first time after untarring the apache directory
I *can* configure, and it does finish... every subsequent time, it doesn't.. *sniff... What
am I to do ?

There is error whatsoever indicating what could be wrong, and I am definately using gcc....

Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66/specs
gcc version egcs-2.91.66 19990314/Linux (egcs-1.1.2 release)


 ./configure --with-layout=RedHat --activate-module=src/modules/php3/libphp3.a

Configuring for Apache, Version 1.3.9
 + using installation path layout: RedHat (config.layout)
 + activated php3 module (modules/php3/libphp3.a)
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for Linux platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
    o php3_module uses ConfigStart/End
 + checking sizeof various data types
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed. This is most likely because your C compiler
** is not ANSI. Apache requires an ANSI C Compiler, such
** as gcc. The above error message from your compiler
** will also provide a clue.
 Aborting!

>How-To-Repeat:
Install RedHat 6.1, install and build mysql and imap4.6 from source , install php3 from source
and make the module
>Fix:
I have no clue... I don't even know where to find the output of what ./configure actually
tries to compile, that's the frustrating part... EVERYTHING else compiles without *any* problems....
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, you need]
[to include <apbugs@Apache.Org> in the Cc line and make sure the]
[subject line starts with the report component and number, with ]
[or without any 'Re:' prefixes (such as "general/1098:" or      ]
["Re: general/1098:").  If the subject doesn't match this       ]
[pattern, your message will be misfiled and ignored.  The       ]
["apbugs" address is not added to the Cc line of messages from  ]
[the database automatically because of the potential for mail   ]
[loops.  If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request from a  ]
[developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]




Mime
View raw message