www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anna Lichtenberger <Anna.lichtenber...@vai.at>
Subject general/5085: Problems to access resources with authentification after publishing a file on the web server
Date Thu, 30 Sep 1999 11:50:22 GMT

>Number:         5085
>Category:       general
>Synopsis:       Problems to access resources with authentification after publishing a
file on the web server
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          support
>Submitter-Id:   apache
>Arrival-Date:   Thu Sep 30 05:00:01 PDT 1999
>Last-Modified:
>Originator:     Anna.lichtenberger@vai.at
>Organization:
apache
>Release:        1.3.6
>Environment:
Windows NT 4.0 SP3
Netscape Communicator 4.61
>Description:
Problems to access resources with authentification after publishing
a file onto the webserver successfully.

1. I activated the PUT method for the webserver in the http.conf file  
   and installed the cgi-Script put.cgi which handles the PUT request.

   <Files *.cgi>
     Options ExecCGI
     SetHandler cgi-script
   </Files>

 
   <Directory "d:/html/tapwww/docu">
     Script PUT /put/put.cgi
    </Directory>

   ScriptAlias /put "d:/html/tapwww/put"

2. I successfully published a file via the Netscape Composer. 
   Netscape Navigator was also running.
   
3. I tried to access a resource with authentification (defined by
   .htacces file) from the webserver, but it didn't work. The resource
   was not the published file and also located in a different directory
   than the published file.
   The following message was permanently written to the 
   access.log file of the webserver:

     148.56.16.63 - - [29/Sep/1999:15:11:56 +0200] "GET /docu/ HTTP/1.0" 401 458
   
   I had to push the stop button of the Navigator to stop it.

   To access the resource from another computer with the Navigator was successful. 
   Accessing a resource with authentication of another Apache webserver was
   successful. 

4. I killed the Navigator and Composer processes and started
   the Navigator again. Then I could access the same resource 
   with authentification successfully.  

5. This behaviour can be repeated every time.


>How-To-Repeat:

>Fix:
no
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, you need]
[to include <apbugs@Apache.Org> in the Cc line and make sure the]
[subject line starts with the report component and number, with ]
[or without any 'Re:' prefixes (such as "general/1098:" or      ]
["Re: general/1098:").  If the subject doesn't match this       ]
[pattern, your message will be misfiled and ignored.  The       ]
["apbugs" address is not added to the Cc line of messages from  ]
[the database automatically because of the potential for mail   ]
[loops.  If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request from a  ]
[developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]




Mime
View raw message