www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Jung <aj...@sz-sb.de>
Subject mod_access/5076: mod_access won't work on all virtual hosts
Date Wed, 29 Sep 1999 07:28:21 GMT

>Number:         5076
>Category:       mod_access
>Synopsis:       mod_access won't work on all virtual hosts
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Sep 29 00:30:01 PDT 1999
>Last-Modified:
>Originator:     ajung@sz-sb.de
>Organization:
apache
>Release:        1.3.9
>Environment:
Solaris 2.7/Sparc/gcc-2.95.1
>Description:
We are running Apache 1.3.9 on two different ports: 80 and 8080

We have some sections like this in our config file:

<location /server-status>
SetHandler server-status
AuthType Basic
require group www-admin
AuthName "Apache Server Status"
</location>

Since the change from 1.3.6 to 1.3.9 this access rule only work
on the virtual host with port 8080 (browser pops password requester), but
not on port 80.

In this case Apache send an error page:

HTTP/1.1 200 OK                                                                
Date: Wed, 29 Sep 1999 07:26:53 GMT                                            
Server: Apache/1.3.9 (Unix) PHP/4.0B2 mod_macro/1.1.1
WWW-Authenticate: Basic realm="Apache Server Status"
Connection: close                  
Content-Type: text/html
                                                                      
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=iso-8859-1">
<META NAME="Reference" CONTENT="OJS">
<META NAME="Title" CONTENT="Official Journal S">
<META NAME="Creator" CONTENT="EUR-OP">
<META NAME="Publisher" CONTENT="EUR-OP">
<META NAME="DatePublication" CONTENT="1999-03-05">
                                                  
<script language="javascript">                    
function go_back() {
        history.back();

.......


Since this worked with 1.3.6 and no modules in our Apache setup have changed,
their might be a problem 
>How-To-Repeat:

>Fix:

>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, you need]
[to include <apbugs@Apache.Org> in the Cc line and make sure the]
[subject line starts with the report component and number, with ]
[or without any 'Re:' prefixes (such as "general/1098:" or      ]
["Re: general/1098:").  If the subject doesn't match this       ]
[pattern, your message will be misfiled and ignored.  The       ]
["apbugs" address is not added to the Cc line of messages from  ]
[the database automatically because of the potential for mail   ]
[loops.  If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request from a  ]
[developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]




Mime
View raw message