www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eldar A. Musayev" <el...@ibm.net>
Subject Re: os-windows/4628: Older DOS-based (16-bit) CGI programs eat memory and eventually fail to execute
Date Thu, 01 Jul 1999 05:23:55 GMT
At 05:42 PM 6/29/99 -0000, stoddard@apache.org wrote:
>There are known problems with 16-bit CGIs in Apache that will be 
>fixed in 1.3.7. Losing memory is not one of the problems we've seen, though.
>Can you verify that the system is -really- running out of memory?
>How large has apache.exe grown when you see the failure?

Probably this is not exactly memory, because problems starts at too low level.
It may be some limit of threads as you described. I checked with 32-bit
applications, the problem is really only for 16-bit CGI, 32-bit ones work
fine.

Below is memory usage before first request, after the first request,
after the first CGI request and subsequent failed CGI requests.
In this test CGI was performed well only once, but it may
take several calls before error appears.

Regards, 
Eldar Musayev

Name(PID)		Start	HTML	1st CGI	2nd CGI
				request		(fail)
Apache.exe(74)		2532	2616	2700	2728	2776	2800	2824	2848	2872	2896	2924	2948
Apache.exe(286)	1744	1744	1744	1744...

------ message ---------------------------------------------------------------
Internal Server Error
The server encountered an internal error or misconfiguration and was unable
to complete your request.
Please contact the server administrator, you@your.address and inform them
of the time the error occurred, and anything you might have done that may
have caused the error.

More information about this error may be available in the server error log.
----------------------------------------------------------------------------
----

accesss.log:
127.0.0.1 - - [30/Jun/1999:08:46:14 -0500] "GET / HTTP/1.1" 200 1673
127.0.0.1 - - [30/Jun/1999:08:46:14 -0500] "GET /apache_pb.gif HTTP/1.1"
200 2326
127.0.0.1 - - [30/Jun/1999:08:49:18 -0500] "GET /cgi-bin/test.exe HTTP/1.1"
200 108
127.0.0.1 - - [30/Jun/1999:08:49:56 -0500] "GET /cgi-bin/test.exe HTTP/1.1"
500 613
... same for each next attempt

error.log:
[Wed Jun 30 08:49:56 1999] [error] [client 127.0.0.1] (2)No such file or
directory: couldn't spawn child process: c:/apache/cgi-bin/test.exe
... same for each attempt

Mime
View raw message