www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From George Winn <gw...@arlut.utexas.edu>
Subject mod_perl/4631: fatal errors during 'make'
Date Tue, 22 Jun 1999 20:29:24 GMT

>Number:         4631
>Category:       mod_perl
>Synopsis:       fatal errors during 'make'
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Jun 22 13:30:01 PDT 1999
>Last-Modified:
>Originator:     gwinn@arlut.utexas.edu
>Organization:
apache
>Release:        1.3.6
>Environment:
SunOS spgsun1 5.7 Generic_106541-05 sun4u sparc SUNW,Ultra-5_10
compiler = gcc
>Description:
I run the 'perl Makefile.PL', which goes ok, but when I run 'make' I get fatal
errors that look like this:

===> modules/perl
gcc -I. -I../../include -I../../include/regex -I../../include/.././os/unix -DSOLARIS2=270
-DMOD_PERL   `/opt/depot/perl-5.004/bin/perl -MExtUtils::Embed -e ccopts` -DNO_PERL_DISPATCH
   -DNO_PERL_POST_READ_REQUEST -DNO_PERL_TRANS -DNO_PERL_HEADER_PARSER  -DNO_PERL_ACCESS -DNO_PERL_AUTHEN
-DNO_PERL_AUTHZ  -DNO_PERL_TYPE -DNO_PERL_FIXUP -DNO_PERL_LOG  -DNO_PERL_INIT -DNO_PERL_CLEANUP
-DNO_PERL_RESTART  -DNO_PERL_STACKED_HANDLERS -DNO_PERL_SECTIONS -DNO_PERL_METHOD_HANDLERS
 -DNO_PERL_SSI -DNO_PERL_DIRECTIVE_HANDLERS   -DMOD_PERL_VERSION=\"1.20\"   -I./os/unix -I../../include
   -c  mod_perl_opmask.c
sh: /opt/depot/perl-5.004/bin/perl: not found
*** Error code 1
make: Fatal error: Command failed for target `mod_perl_opmask.o'
Current working directory /mnt/disk1/opt/depot/apache/src/modules/perl
*** Error code 1
make: Fatal error: Command failed for target `all'
Current working directory /mnt/disk1/opt/depot/apache/src/modules
*** Error code 1
make: Fatal error: Command failed for target `subdirs'
Current working directory /mnt/disk1/opt/depot/apache/src
*** Error code 1
make: Fatal error: Command failed for target `apache_httpd'

The line, "sh: /opt/depot/perl-5.004/bin/perl: not found" is the bug I believe
Although a copy of perl5004 is in that dir, the binary is called 'perl5'.
'perl' doesn't exist.  I don't have access to this dir, as it's NFS mounted
and I don't have root on the system, and thus I cannot create a symlink.
The weird thing is that I'm executing /opt/bin/perl, which it uses in other
parts of the make just fine.  Why is it switching what binary it wants to use?
Also, I have a complete 'perl Makefile.PL' log and 'make' log.  Email me, and
I will send them.  Thanks a million if you can help with this.
>How-To-Repeat:
i dunno
>Fix:
Make whatever is looking for this incorrect binary point to the binary
that I executed in the initial 'perl Makefile.PL'
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, you need]
[to include <apbugs@Apache.Org> in the Cc line and make sure the]
[subject line starts with the report component and number, with ]
[or without any 'Re:' prefixes (such as "general/1098:" or      ]
["Re: general/1098:").  If the subject doesn't match this       ]
[pattern, your message will be misfiled and ignored.  The       ]
["apbugs" address is not added to the Cc line of messages from  ]
[the database automatically because of the potential for mail   ]
[loops.  If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request from a  ]
[developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]




Mime
View raw message