www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Abraham <richard.abra...@mnr.gov.on.ca>
Subject general/4550: ENVIRONMENT VARIABLE LD_LIBRARY_PATH becomes corrupted.
Date Wed, 09 Jun 1999 18:45:45 GMT

>Number:         4550
>Category:       general
>Synopsis:       ENVIRONMENT VARIABLE LD_LIBRARY_PATH becomes corrupted.
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Jun  9 11:50:01 PDT 1999
>Last-Modified:
>Originator:     richard.abraham@mnr.gov.on.ca
>Organization:
apache
>Release:        1.3.6
>Environment:
Digital Unix V4.0 564 alpha
>Description:
I have a cgi-script which submits a at job.
In the atjob file all environment variables are set.
There are a lot more than at APACHE version 1.2
All seem to be Okay except for LD_LIBRARY_PATH which is set in
the cgi-script to /remo6/arcexe71/lib:/usr/lib.
In the atjob file it appears as:
export LD_LIBRARY_PATH; LD_LIBRARY_PATH='M-^?268M-^?0M-^?/remo6/arcexe71/lib:/usr/lib

The jibberish prepended to the value did not appear with APACHE version 1.2.
The jibberish does not appear for any other environment variable, just
LD_LIBRARY_PATH.
I tried changing values etc., nothing worked.
I tried setting another environment variable called LIBRARY_PATH, and no
jibberish appeared.
I got around the problem by moving the libraries to /usr/lib and commenting
out the setenv LD_LIBRARY_PATH statement in the cgi-script.  So the problem
is not critical.
>How-To-Repeat:
No it's on an Intranet sight.
>Fix:
Other than moving the libraries.  No.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, you need]
[to include <apbugs@Apache.Org> in the Cc line and make sure the]
[subject line starts with the report component and number, with ]
[or without any 'Re:' prefixes (such as "general/1098:" or      ]
["Re: general/1098:").  If the subject doesn't match this       ]
[pattern, your message will be misfiled and ignored.  The       ]
["apbugs" address is not added to the Cc line of messages from  ]
[the database automatically because of the potential for mail   ]
[loops.  If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request from a  ]
[developer.  Reply only with text; DO NOT SEND ATTACHMENTS!     ]




Mime
View raw message