www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Godmar Back <gb...@marker.cs.utah.edu>
Subject Re: general/4219: JServ1.0b3 does not build: only compiles Hello.java
Date Mon, 12 Apr 1999 06:02:37 GMT

Now that I was finally able to run the sample servlet, here's
a bit more feedback you may or may not find useful:

First I should mention that I'm using Kaffe as my JVM.
Therefore,
wrapper.classpath=@JDK_CLASSES@

produced this
wrapper.classpath=

(I assume because I didn't define JDK_HOME?) 
which in turn made JServ crash like so.
[11/04/1999 23:46:22:246] (EMERGENCY) Error initializing protocols
[11/04/1999 23:48:54:736] (ERROR) wrapper: file /opt/Apache-JServ-1.0b3/example/jserv.properties
(line 53) wrapper.classpath must be called with a parameter
[11/04/1999 23:48:54:737] (ERROR) an error returned initializing protocol "wrapper"
[11/04/1999 23:48:54:737] (ERROR) in init all protocols "wrapper" returned an error
[11/04/1999 23:48:54:737] (EMERGENCY) Error initializing protocols

You may be able to fix this with something like
@HAVE_JDK_CLASSES@wrapper.classpath=@JDK_CLASSES@
and set HAVE_JDK_CLASSES accordingly.

Secondly, in examples/jserv.conf.in, this line is wrong:

@LOAD_OR_NOT@LoadModule jserv_module libexec/mod_jserv.so

It does not take the $prefix and $exec_prefix variables into
account.  After make install, mod_jserv.so ended up in 
$prefix/lib/mod_jserv.so for me.  Note that I specified an alternate
location with --prefix when configuring.
Unfortunately, I don't know how to fix this easily.

	- Godmar


Mime
View raw message