www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Godmar Back <gb...@cs.utah.edu>
Subject Re: general/4219: JServ1.0b3 does not build: only compiles Hello.java
Date Mon, 12 Apr 1999 04:30:00 GMT
The following reply was made to PR general/4219; it has been noted by GNATS.

From: Godmar Back <gback@cs.utah.edu>
To: gback@cs.utah.edu (Godmar Back)
Cc: gback@cs.utah.edu, apbugs@hyperreal.org, apache-bugdb@apache.org
Subject: Re: general/4219: JServ1.0b3 does not build: only compiles Hello.java
Date: Sun, 11 Apr 1999 22:23:43 -0600 (MDT)

  I again fell victim to this time not automake, but autoconf
 (and my own stupidity).  It's not --with-apache-dir, it's --with-apache-install.
 Of course, configure never complains if you specify an option that doesn't
 exist.  It's like it doesn't care.
 
 With --with-apache-install, Apache configures successfully, even without giving
 --with-apache-src.  Now I'm even more confused: how did
 MAKE_LIBJSERV get set?  I thought it required $apache_dir_is_src to be
 true... but wait, let's look at it again:
 
 AM_CONDITIONAL(MAKE_LIBJSERV, test x$apache_dir_is_src = xfalse)
 
 This probably means: set MAKE_LIBJSERV to true *unless* apache_dir_is_src
 is set to false (in which case it wouldn't make sense...)  
 Then it would make more sense.
 
 So, I guess this leave only two problems on your end of things:
 First, the problem with configuring outside the srcdir, and second the
 problem with configure not reporting what is going wrong.
 
 Thanks,
 
 	- Godmar
 

Mime
View raw message