www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olly Betts <o...@muscat.co.uk>
Subject config/4200: ./configure --help , -help , -h don't work
Date Tue, 06 Apr 1999 11:20:19 GMT

>Number:         4200
>Category:       config
>Synopsis:       ./configure --help , -help , -h don't work
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Apr  6 04:30:00 PDT 1999
>Last-Modified:
>Originator:     olly@muscat.co.uk
>Organization:
apache
>Release:        1.3.6
>Environment:
SunOS bagpuss 5.6 Generic sun4u sparc SUNW,Ultra-1
>Description:
configure doesn't recognise "--help", "-help", or "-h", though the script
looks like it should, plus "./configure" with no args suggests you should
"at least run './configure --help' for a compact summary of available options."

--help just seems to hang; -h and -help seem to be ignored.
>How-To-Repeat:
./configure --help
>Fix:
Not as such I'm afraid.  But the configure script sets a variable "help"
to "yes" if any of these options is set, but never checks it - perhaps that's
the problem?
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message