www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lachlan Cranswick <l.m.d.cransw...@dl.ac.uk>
Subject general/4191: Child Server hangs on HostnameLookups to lame DNS Servers
Date Sat, 03 Apr 1999 17:40:03 GMT

>Number:         4191
>Category:       general
>Synopsis:       Child Server hangs on HostnameLookups to lame DNS Servers
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Sat Apr  3 09:50:01 PST 1999
>Last-Modified:
>Originator:     l.m.d.cranswick@dl.ac.uk
>Organization:
apache
>Release:        1.3.6
>Environment:
SGI O2 - uname -a = IRIX 6.5 01221553 IP 32
1.3.6 compiled with standard SGI cc compiler as 
gcc 2.8.1 compiled apache was giving problems with stating all
non-resolved IP address as 255.255.255.255 for apache,
secure shell, etc.
>Description:
After doing an upgrade from Apache 1.3.3 to 1.3.6:
Hung child servers seem to be occuring in the D (DNS lookup)
stage with Apache 1.3.6.  This was not seen with 1.3.3.
Possible problem with apache doing lookups involving
servers that have:
 "Lame Server Delegation" or "Unexpected Reponse from Server"
(If you use nslookup, if gives the response:  can't
find X.X.X.X: "Server Error")

/server-status
   M  CPU   SS  Req  Conn  Child  Slot      Client           VHost
.. D 11.82 16529 0   0.0   18.28 18.94  141.99.196.217  www.ccp14.ac.uk
.. D 10.90 48424 0   0.0   22.19 22.19  206.48.227.102  www.ccp14.ac.uk
.. D 16.00 77922 0   0.0   14.42 14.42   12.10.201.31   www.ccp14.ac.uk

"Non Existent host/domain" seems to handle things OK - at least in
getting through the DNS lookup stage.  e.g., 139.82.89.14
=======

Doing the config and setup from scratch, Server status shows a
gradual buildup over a few days of hung servers on DNS lookup:

D   206.48.227.15
D   206.48.227.59
D   206.48.227.114
D   206.41.178.180
D   198.164.180.76

---

Have tried posting to the newsgroups to see if other people
have found this - no response - not even the typical
insults for implying/inferring Apache has bags.
Have not managed to find this type of
bug in the Apache bug database.
>How-To-Repeat:
If you can rig up a lame DNS server upstream from the
client browser, this should be reproduceable.
>Fix:
Could Lame DNS and related DNS server problems be 
handled in the same way as "Non Existent host/domain"
when doing a DNS lookup resolving the IP number to a
name.

Also, for IP address that do not resolve to names, 
might it be possible to send custom webpages depending
on the reason for the IP address not resolving - lame
DNS, Non-existent host/domain.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message