www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ralf S. Engelschall" <...@engelschall.com>
Subject Re: general/3898: --prefix / --exec-prefix "confusion"
Date Wed, 10 Mar 1999 13:10:02 GMT
The following reply was made to PR general/3898; it has been noted by GNATS.

From: "Ralf S. Engelschall" <rse@engelschall.com>
To: apbugs@apache.org
Cc:  Subject: Re: general/3898: --prefix / --exec-prefix "confusion"
Date: Wed, 10 Mar 1999 13:23:37 +0100

 In article <19990214002916.21528.qmail@hyperreal.org> you wrote:
 
 > # uname -a
 > Linux BabelTech.dk 2.1.131 #7 SMP Mon Dec 14 19:08:12 CET 1998 i686 unknown
 >>Description:
 > I'm trying to build/install apache in a "shareable" fashion, where the SW is
 > installed to (in my case) /Packages/Linux-ix86/apache-1.3.4, but is accessed
 > via /usr/local/* - this is managed by using cmu-depot.
 > 
 > Usually (mainly other gnu-autoconf kits) it's sufficient to do a "configure --prefix=/usr/local
..."
 > followed my a "make" and then a "make install prefix=/Packages/Linux-ix86/apache-1.3.4",
 > however the Apache-kit ignores the "prefix=.." in the "make install .." command,
 > and trying to use "configure --prefix=/Packages/Linux-ix86/apache-1.3.4
 > --exec-prefix=/usr/local" results in some of the stuff (mainly the support-tools)
 > going directly to /usr/local, while the rest goes where it's supposed to go.
 > 
 > The problem is compounded by the fact that the /usr/local hierarchy is strictly
 > maintained by cmu-depot, which means that stuff that hasn't been added by cmu-depot
 > simply gets deleted.
 > 
 > Not a serious problem, but definately an annoying one (to me at least ;-) )
 
 What you're searching for is "make install root=....", I guess.
 Look inside the INSTALL file for details.
 
                                        Ralf S. Engelschall
                                        rse@engelschall.com
                                        www.engelschall.com

Mime
View raw message