www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom Zhang <tom_zh...@sts.ne.mediaone.net>
Subject os-windows/3687: if server start as NT service it fails output data filter.
Date Sat, 16 Jan 1999 04:44:45 GMT

>Number:         3687
>Category:       os-windows
>Synopsis:       if server start as NT service it fails output data filter.
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Jan 15 20:50:00 PST 1999
>Last-Modified:
>Originator:     tom_zhang@sts.ne.mediaone.net
>Organization:
apache
>Release:        1.3.4
>Environment:
WinNT 4.0 SP3
>Description:
If I start server as NT service, the data filtering CGI program will not produce 
output. Everything works fine if running in console mode. 

The error log as 

Apache: [Fri Jan 15 23:11:00 1999] [error] [client 223.128.127.100] Premature end of script
headers: c:/prog/apache/cgi-bin/gx.cgi
[Fri Jan 15 23:13:31 1999] file .\main\http_main.c, line 5891, assertion "start_mutex" failed

 
>How-To-Repeat:
It happens when use Netscape Application Builder on Apache server.
Their sample fails. 
>Fix:

>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message