www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Etzell <etz...@mindframe.com>
Subject Re: os-windows/3599: Apache hangs after heavy/long usage
Date Wed, 30 Dec 1998 18:10:00 GMT
The following reply was made to PR os-windows/3599; it has been noted by GNATS.

From: Steve Etzell <etzell@mindframe.com>
To: Dirk.vanGulik@jrc.it, apbugs@Apache.Org
Cc:  Subject: Re: os-windows/3599: Apache hangs after heavy/long usage
Date: Wed, 30 Dec 1998 10:49:43 -0600

 Dirk-WIllem van Gulik wrote:
 > 
 > Steve Etzell wrote:
 > 
 > > >Number:         3599
 > > >Category:       os-windows
 > > >Synopsis:       Apache hangs after heavy/long usage
 > > >Confidential:   no
 > > >Severity:       critical
 > > >Priority:       medium
 > > >Responsible:    apache
 > > >State:          open
 > > >Class:          sw-bug
 > > >Submitter-Id:   apache
 > > >Arrival-Date:   Mon Dec 28 08:20:00 PST 1998
 > > >Last-Modified:
 > > >Originator:     etzell@mindframe.com
 > > >Organization:
 > > apache
 > > >Release:        1.3b6
 > > >Environment:
 > > Using WinNT with sp4.  Dell PowerEdge2300 5Gb HD, 512Mb RAM.
 > > >Description:
 > >Apache is being used with Cold Fusion to server a high traffic commerce
 > > site.  This site easily saturates a T1 line with traffic.  We started
 > > using apache over Netscape Enterprise 3.5.1 for performance reasons.
 > > I originally configed apache with MaxRequestsPerChild set to 300000.
 > > Apache hung when it hit about 30000.  I set MaxRequestsPerChild to 0
 >  and the apache worked fine for about a day and a half.  It never totaly
 > > hung but most people got a 'server too busy' response.  Stop and
 > > start the apache process and everything was fine.
 > 
 > Although this might have everything to do with Solaris libraries, rather
 > than Cold Fusion; I:ve ran into much the same on Solaris 2.5 around the
 > 10k requests per single child. (Solaris was for us about three times as
 > fast, on the same hardware) It clearly is not a memory leak; and running
 > it with truss revealed it whas in the ODBC of the cold fusion module.
 > Lowering the MaxRequestsPerChild to 2k 'solved' the issue. Interesting
 > to note; it only seemed to be the number of request, not the load,
 > or the time in which it happened and only when ODBC was involved.
 > The move to solaris caused such a low MaxRequestsPerChild not to
 > have any noticable impact
 > 
 > Are you sure that on NT there is such an impact to warrant a high max
 > request per child, it is there exactly to prevent this sort of
 > resource hog hangs ?
 
 We have Apache running on another server that is not using CF
 nearly as much and we never have a problem with that site.
 I tried setting MaxRequestsPerChild to 5000.  It ran for
 about 20 minutes before restarting itself.  In the next 10
 minutes after that the server became busy and received
 5000 access in about 10 minutes.  Apache hung while servicing
 98 request (150 max) and had 5100 total access.  I waited
 about 2 minutes for the process to restart itself and it
 never did.  I stopped and started the process manually.
 
 I tried setting it to 2000 as you suggested and Apache just
 hung faster while servicing about the same load.  I set
 MaxRequestsPerChild back to 0 so it will at least run longer
 before hanging.  I have Apache and CF stop and start at
 0300 every day to prevent problems.  It still hangs at
 least once a day in its current configuration.  
 
 I'm fairly certain that Apache hangs because we are using
 CF.  I need to know whether it is something I can nag Allaire
 about or if it is something that can be fixed on the Apache
 end.  I have a much better chance of keeping this site up
 if there is a modification I can make to Apache.
 
 > > I saw a bugreport about the MaxRequestsPerChild.  I only mentioned
 > > it becuase the server hang for the MaxRequestsPerChild is exactly
 > > the same as the hang over extended use.
 > > >How-To-Repeat:
 > > set MaxRequestsPerChild to anything but 0 or Use the site under
 > > heavy traffic with cold fusion for a while.
 > > >Fix:
 > > No
 > > >Audit-Trail:
 > > >Unformatted:
 > > [In order for any reply to be added to the PR database, ]
 > > [you need to include <apbugs@Apache.Org> in the Cc line ]
 > > [and leave the subject line UNCHANGED.  This is not done]
 > > [automatically because of the potential for mail loops. ]
 > > [If you do not include this Cc, your reply may be ig-   ]
 > > [nored unless you are responding to an explicit request ]
 > > [from a developer.                                      ]
 > > [Reply only with text; DO NOT SEND ATTACHMENTS!         ]

Mime
View raw message