www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles R.Bowman <crbow...@sojosoft.com>
Subject config/3560: LogFormat error message when executing httpd for the first time
Date Fri, 18 Dec 1998 23:28:22 GMT

>Number:         3560
>Category:       config
>Synopsis:       LogFormat error message when executing httpd for the first time
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Dec 18 15:30:01 PST 1998
>Last-Modified:
>Originator:     crbowman@sojosoft.com
>Organization:
apache
>Release:        1.3.3
>Environment:
Linux 2.0.36 (Redhat 5.2)
>Description:
After installing Apache, upon executing httpd for the first time, I received the error message
"LogFormat takes 1-2 arguments, a log format string (see docs) and an optional format name".
>How-To-Repeat:

>Fix:
I corrected the httpd.conf file myself by placing backslashes before the inside quotation
marks in the LogFormat directives.
The two corrected lines (lines 159 & 160) read as follows:
  LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"{User-Agent}i\"" combined
  LogFormat "%h %l %u %t \"%r\" %>s %b" common

Everything worked fine once I did this.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message