www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Grant Conklin <gconk...@home.com>
Subject general/3275: not building on intel Solaris 2.6
Date Fri, 23 Oct 1998 01:24:17 GMT

>Number:         3275
>Category:       general
>Synopsis:       not building on intel Solaris 2.6
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Oct 22 18:30:00 PDT 1998
>Last-Modified:
>Originator:     gconklin@home.com
>Organization:
apache
>Release:        apache 1.3.3
>Environment:
Having problems compiling...
  Solaris 2.6 for x86
  GNUg77 0.5.2.1  which is equivalent to GNUgcc 2.7.2.3
  Perl 5.004.04
Tried Configuration file with WANTHSREGEX set to default and yes (neither worked).
>Description:
-----snip-----
C247151-B# ./configure
Configuring for Apache, Version 1.3.3
 + Warning: Configuring Apache with default settings.
 + This is probably not what you really want.
 + Please read the README.configure and INSTALL files
 + first or at least run './configure --help' for
 + a compact summary of available options.
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for Solaris 260 platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
 + doing sanity check on compiler and options
Creating Makefile in src/support
Creating Makefile in src/main
Creating Makefile in src/ap
Creating Makefile in src/regex
Creating Makefile in src/os/unix
Creating Makefile in src/modules/standard
C247151-B# /usr/local/bin/make
===> src
make[1]: Entering directory `/usr/local/src/apache_1.3.3'
make[2]: Entering directory `/usr/local/src/apache_1.3.3/src'
===> src/os/unix
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=260 `../../apaci` os.c
gcc -c  -I../../os/unix -I../../include   -DSOLARIS2=260 `../../apaci` os-inline.c
rm -f libos.a
ar cr libos.a os.o os-inline.o
make[3]: ar: Command not found
make[3]: *** [libos.a] Error 127
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/local/src/apache_1.3.3/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/local/src/apache_1.3.3'
make: *** [build] Error 2
-----snip------

Was successful on same system with Solaris 2.5.

Help!
>How-To-Repeat:

>Fix:
do I have incorrect compilers or am I missing classes??
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message