www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@znep.com>
Subject Re: general/3260: Strange behaviour of Apache under heavy load
Date Wed, 21 Oct 1998 17:20:00 GMT
The following reply was made to PR general/3260; it has been noted by GNATS.

From: Marc Slemko <marcs@znep.com>
To: Andreas Jung <ajung@sz-sb.de>
Cc: apbugs@hyperreal.org
Subject: Re: general/3260: Strange behaviour of Apache under heavy load
Date: Wed, 21 Oct 1998 10:18:26 -0700 (PDT)

 On 21 Oct 1998, Andreas Jung wrote:
 
 > SunOS moses 5.6 Generic sun4u sparc SUNW,Ultra-2      
 > >Description:
 > I encountered the following problems with Apache 1.3.3 during
 > a mass test (about 250 mostly parallel wgets on the same URL):
 > 
 > - in one case Apache stop serving any request with the following message:
 > [Wed Oct 21 11:42:10 1998] [error] server reached MaxClients setting, consider raising
the MaxClients setting
 >   I had to restart Apache after this message
 
 Are you sure your client didn't just have all the connections open and was
 keeping them open?  It sounds to me like it just kept opening connections
 until it reached the configured maximum, then couldn't open any more.  I
 don't see any reason to think anything is wrong with Apache in that case.
 
 > 
 > - after increasing the number of maxclients I got lots of messages:
 >   Wed Oct 21 11:42:33 1998] [crit] [client 10.2.0.42] (13)Permission denied: /home/.htaccess
pcfg_openfile: unable to check htaccess file, ensure it is readable
 >   Why will Apache look in /home/.htaccess ? Serverroot und DOcumentroot are somewhere
deep under /home !
 
 Please read http://www.apache.org/docs/misc/perf-tuning.html
 
 > 
 > - if Apache is started with -X I see MORE than one httpd processes although
 >   the documentation says it is running in single-process mode
 > 
 >    moses@/home/ajung/testbed(54)% ps -ef | grep httpd
 >    ajung    55 16424  1 12:35:29 pts/21   0:00 ./httpd -X -f /home/ajung/testbed/SZ.conf
 >    ajung    57    56  0 12:35:30 pts/21   0:00 ./httpd -X -f /home/ajung/testbed/SZ.conf
 >    ajung    60  7669  0 12:35:31 pts/31   0:00 grep httpd
 >    ajung    56    55  0 12:35:30 pts/21   0:00 ./httpd -X -f /home/ajung/testbed/SZ.conf
                  
 
 
 Yes, there is supposed to be more than one process.  There is supposed to
 be a parent and a child.  Do you have any extra modules (eg. jserv)
 compiled in?  Certain modules will start an extra child.
 

Mime
View raw message