www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Insulander <m...@isk.kth.se>
Subject mod_so/3189: httpd: module "Segmentation Fault at startup using DSO
Date Mon, 12 Oct 1998 11:08:13 GMT

>Number:         3189
>Category:       mod_so
>Synopsis:       httpd: module "Segmentation Fault at startup using DSO
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon Oct 12 04:10:00 PDT 1998
>Last-Modified:
>Originator:     main@isk.kth.se
>Organization:
apache
>Release:        1.3.3
>Environment:
OS: Solaris 2.6
Compiler: SUN Proworks cc (/usr/ucb/cc)
>Description:
Loading a module at runtime with DSO used to work fine with Apache 1.3.0
on the exact same system. I tried compiling mod_status as shared.

This is how I configured Apache 1.3.3:
CC=cc ./configure --prefix=/opt/local/apache/1.3.3 --enable-module=so --enable-shared=log_referer
--enable-rule=SHARED_CORE

And this is what it says when I run it (with a LoadModule directive):
httpd: module "Segmentation Fault

No coredump (as far as I can see) or nothing, just that.
>How-To-Repeat:

>Fix:
Compare 1.3.0 and 1.3.3, and see what has changed.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message