www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From r..@apache.org
Subject Re: os-sco/2533: Apache 1.3.0 won't build with Dynamic Shared Object (DSO) support
Date Thu, 10 Sep 1998 08:59:43 GMT
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]


Synopsis: Apache 1.3.0 won't build with Dynamic Shared Object (DSO) support

Comment-Added-By: rse
Comment-Added-When: Thu Sep 10 01:59:43 PDT 1998
Comment-Added:
Ok, the `-lx -ltinfo -lm' was now comitted for Apache
1.3.2, but for the USE_FCNTL_SERIALIZED_ACCEPT: 
The only correct solution would be to dispatch
for 5.0.0 and 5.0.2 and avoid it only for >= 5.0.4.
So what we need is a patch which does the following:
1. Recognize SCO versions in src/helpers/GuessOS
2. Set the SCO5 define not only to be defined, instead
   it should be set to 500, 502 or 504, etc. according
   to what GuessOS determined.
3. The #define USE_FCNTL_SERIALIZED_ACCEPT should
   be surrounded by a
   #if defined(SCO5) && (SCO5 >= 500 && SCO5 < 504)
Can you contribute this patch, because I've still
no chance to work under a SCO box myself. I've
no such platform available...


Mime
View raw message