www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivo Batistic <...@ifs.hr>
Subject mod_include/2974: SSI does not work within virtual host web tree
Date Wed, 09 Sep 1998 13:50:39 GMT

>Number:         2974
>Category:       mod_include
>Synopsis:       SSI does not work within virtual host web tree
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Sep  9 07:00:00 PDT 1998
>Last-Modified:
>Originator:     ivo@ifs.hr
>Organization:
apache
>Release:        1.3.1
>Environment:
Linux eskola.hfd.hr 2.0.34 #1 Tue Jun 9 18:41:51 CEST 1998 i686 unknown
Debian 2.0, glibc.
>Description:
If I try to use  SSI+XBitHack (but also with .shtml type)
within virtual host DocumentRoot tree, "<!--#" SSI commands are ignored,
and the are sent to the clients as a comments.

However SSI is working as expected if it is used
within "default" DocumentRoot tree.
>How-To-Repeat:
Ckeck SSI with commented & uncommented <VirtualHost ..> host tags.

httpd.conf:
## <VirtualHost eskola1.hfd.hr:80>
DocumentRoot /var/www1
....
## </VirtualHost>

access.conf:

<Directory>
Options Includes ....
XBitHack on
...
</Directory>
>Fix:

>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]
[If you do not include this Cc, your reply may be ig-   ]
[nored unless you are responding to an explicit request ]
[from a developer.                                      ]
[Reply only with text; DO NOT SEND ATTACHMENTS!         ]




Mime
View raw message