www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Falck <greg.fa...@lmco.com>
Subject general/2728: DSO not working - similar to PR 2349
Date Tue, 28 Jul 1998 14:08:01 GMT

>Number:         2728
>Category:       general
>Synopsis:       DSO not working - similar to PR 2349
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Jul 28 07:10:00 PDT 1998
>Last-Modified:
>Originator:     greg.falck@lmco.com
>Organization:
apache
>Release:        1.3.1
>Environment:
SunOS e5sct 5.5 Generic_103093-22 sun4m sparc
gcc 2.8.1
>Description:
I'm trying to get mod_info and mod_status to load dynamically and receive the
following error:

sbin/apachectl configtest
Syntax error on line 27 of /3rdparty/www/apache/etc/httpd.conf:
Cannot load /3rdparty/www/apache/libexec/mod_info.so into server: ld.so.1:
/3rdparty/www/apache/sbin/httpd: fatal: relocation error: symbol not found:
ap_user_id: referenced in /3rdparty/www/apache/libexec/mod_info.so

Same for mod_status.
Slightly different for mod_speling - complains about the symbol ap_table_get.

Greg
>How-To-Repeat:
#!/bin/sh
##
##  config.status -- APACI auto-generated configuration restore script
##
##  Use this shell script to re-run the APACI configure script for
##  restoring your configuration. Additional parameters can be supplied.
##

./configure \
"--prefix=/3rdparty/www/apache" \
"--enable-module=proxy" \
"--enable-module=auth_dbm" \
"--enable-shared=remain" \
"--disable-module=auth_db" \
"--shadow" \
$*
>Fix:
No
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message