www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elliott Martin <elli...@london.codemasters.com>
Subject general/2620: Environment variables not passed to NMAKE in 'Makefile.nt'
Date Wed, 15 Jul 1998 10:44:19 GMT

>Number:         2620
>Category:       general
>Synopsis:       Environment variables not passed to NMAKE in 'Makefile.nt'
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          support
>Submitter-Id:   apache
>Arrival-Date:   Wed Jul 15 03:50:00 PDT 1998
>Last-Modified:
>Originator:     elliott@london.codemasters.com
>Organization:
apache
>Release:        1.3.0
>Environment:
Win95/NT VC++ 5.0
>Description:
The %LONG% environment variable specified in the CFG macros in the 'Makefile.nt' makefile
do not get passed to NMAKE.
>How-To-Repeat:
Run the original makefile as is under Win95 or NT.
>Fix:
I know this bug has already been fixed by adding 'LONG=%LONG%' to the makefile, but I found
that this problem actually occurs due to a lack of environment space.  I don't know how much
use this will be (your current solution seems quicker and easier), but if you add 'command.com
/E:1024 /C' before the NMAKE commands, therefore increasing the amount of memory allocated
to the environment, the problem seems to be fixed!
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message