www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David MacKenzie <...@uu.net>
Subject documentation/2546: A backward incompatibility wasn't noted in the 1.2 to 1.3 upgrade notes.
Date Thu, 02 Jul 1998 20:16:40 GMT

>Number:         2546
>Category:       documentation
>Synopsis:       A backward incompatibility wasn't noted in the 1.2 to 1.3 upgrade notes.
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          doc-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Jul  2 13:20:01 PDT 1998
>Last-Modified:
>Originator:     djm@uu.net
>Organization:
apache
>Release:        1.3.0
>Environment:
Any.
>Description:
Some of our customers' CGI scripts broke when we upgraded to 1.3.0, because
they used the REMOTE_HOST environment variable.  Since we run with DNS lookups
turned off, this disappeared in 1.3.0.  Yet there is no mention of the change
in http://www.apache.org/docs/upgrading_to_1_3.html
They'll have to switch to using REMOTE_ADDR, but there should be a warning
about that in the upgrade notes.  It was certainly not previously clear
that it was wrong to assume that REMOTE_HOST would always be set.
>How-To-Repeat:
Probably more than a few CGI scripts are affected by this.
>Fix:
Please add a mention of this problem in the upgrade notes.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message