www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dax Kelson <dkel...@inconnect.com>
Subject general/2349: DSO isn't working for me.
Date Thu, 04 Jun 1998 17:20:52 GMT

>Number:         2349
>Category:       general
>Synopsis:       DSO isn't working for me.
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Jun  4 10:30:00 PDT 1998
>Last-Modified:
>Originator:     dkelson@inconnect.com
>Organization:
apache
>Release:        1.3b7
>Environment:
SunOS ultra1 5.6 SunOS sun4u sparc SUNW,Ultra-1

I've tried gcc 2.7.2.3 and egcs 1.02 for compilers with same result.
>Description:
My problem orginally started when I tried to use PHP and dl(/path/imap.so) and it
kept getting "relocation errors" with Apache 1.2.6 and PHP 3.0RC3.

So I'm trying again with Apache 1.3b7 and PHP3.0RC5.  I decided to try make PHP a
DSO module for Apache to see if that would work, and if it didn't, and I could fix
it, I could probably fix the PHP dl(/path/imap.so) problem.

./apachectl start
Syntax error on line 26 of /usr/local/apache/etc/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp3.so into server: ld.so.1: /usr/loca
l/apache/sbin/httpd: fatal: relocation error: file /usr/local/apache/libexec/lib
php3.so: symbol ap_user_id: referenced symbol not found
./apachectl start: httpd could not be started
>How-To-Repeat:
Try it.
>Fix:
I'm not sure.  Help please.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message