www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sriram Ramkrishna <sramk...@ichips.intel.com>
Subject config/2301: ROOT/src/include/conf.h must have valid default group and owner
Date Thu, 28 May 1998 00:19:14 GMT

>Number:         2301
>Category:       config
>Synopsis:       ROOT/src/include/conf.h must have valid default group and owner
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed May 27 17:20:01 PDT 1998
>Last-Modified:
>Originator:     sramkris@ichips.intel.com
>Organization:
apache
>Release:        1.3b7
>Environment:
Running FreeBSD 2.2.5-RELEASE FreeBSD patchlevel 0, on an PPRO 200Mhz.
with 64megs of ram.  On a network with minimum group and passwd files
and NIS to supplement the other group and passwd entries.
>Description:
It seems under FreeBSD 2.2.5, if you do not have a valid group and owner
in the conf.h file, httpd will not run.  Even if you override the defaults
in the ROOT/etc/httpd.conf file.  They must be valid before you can override
the defaults.  The current default is nouser and nogroup.  If you compile
with the current defaults, it checks for nouser and nogroup regardless
of what your set up is. 
>How-To-Repeat:
Simply use the default setup with freebsd 2.2.5.
>Fix:
The way to fix it, is to put a valid group and owner DEFAULT_OWNER and
DEFAULT_GROUP defines in SRC_ROOT/src/include/conf.h.  That should fix
everything.

I do not know if this was reported before.  I couldn't find any bug reports
on this problem at all in any of the databases.  So hopefully this is not a 
duplicate bug.
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message