www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lupe Christoph <l...@alanya.m.isar.de>
Subject documentation/2169: --add-module is insufficient
Date Sat, 02 May 1998 14:51:05 GMT

>Number:         2169
>Category:       documentation
>Synopsis:       --add-module is insufficient
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          change-request
>Submitter-Id:   apache
>Arrival-Date:   Sat May  2 08:00:00 PDT 1998
>Last-Modified:
>Originator:     lupe@alanya.m.isar.de
>Organization:
apache
>Release:        1.3b6
>Environment:
SunOS alanya.m.isar.de 5.6 Generic i86pc i386 i86pc
GCC 2.8.1
>Description:
The documentation does not describe how a module containing several
files is added. Example: PHP/FI 2.0b12 needs mod_php.c, mod_php.h,
and libphp.a. Also, it requires the addition of a long string
of options to the Makefile in src.

(Yes, I know PHP/FI is obsolescent. But It's still around, and
PHP 3 is not yet fully released.)
>How-To-Repeat:
Try adding PHP/FI 2.0 to Apache 1.3b6.
>Fix:
Change documentation to tell where to do changes. E.g. copy all files
to modules/extra, then edit src/Makefile. (Or src/Makefile.in ?)
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message