www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Slemko <ma...@znep.com>
Subject Re: protocol/1813: After CGI (POST) HTTP-Headers shown in browser and internal Error "OK" (200)
Date Fri, 13 Mar 1998 01:20:00 GMT
The following reply was made to PR protocol/1813; it has been noted by GNATS.

From: Marc Slemko <marcs@znep.com>
To: Carsten Schabacker <c.schabacker@gis.ibfs.de>
Cc: Apache bugs database <apbugs@apache.org>
Subject: Re: protocol/1813: After  CGI (POST) HTTP-Headers shown in    browser and internal
Error "OK" (200)
Date: Thu, 12 Mar 1998 18:01:18 -0700 (MST)

 On 17 Feb 1998, Carsten Schabacker wrote:
 
 > >>>>> In <Pine.BSF.3.95.980216094021.2516E-100000@alive.znep.com>

 > >>>>>	Marc Slemko <marcs@znep.com> wrote:
 > MS> On 16 Feb 1998, Carsten Schabacker wrote:
 > 
 > Hi Marc,
 > 
 > MS> Are you sure it is not a problem with mod_python?
 > No, but i can make a try without mod_python ... you are right, the problem
 > seems to be in mod_python. 
 > 
 > This is what i found out
 > external python:  GET ok   POST ok
 > mod_python:       GET ok   POST not ok
 > 
 > (mod_python.c Revision: 4.2 Date: 1998/01/25 10:29:29)
 > 
 > I think i go back to external python.
 > 
 > MS> Is there any authentication required for the document in question?
 > Yes, there is a .htaccess file in the directory where the html-pages are 
 > stored and in the /cgi-sbin/ directory.
 
 And if you remove the authentication, does it work?
 
 What client are you using?
 
 > 
 > MS> > >Fix:
 > MS> I'm not sure I understand what you are saying here...
 > As i understand the http protocol there must be a empty newline between the
 > headers and the body (like in a e-mail), right ?
 > If so: if you put out a empty string followed by a newline the header will
 > end and the body starts, this is what i thought what goes wrong.
 
 Erm... but what would be doing that?  If the script is doing it, it is
 broken.
 
 Give a snapshot of the current to-be-1.2.6 tree at:
 
 	http://dev.apache.org/from-cvs/1.2/
 
 It may fix the issue.
 

Mime
View raw message