www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Reinhardt <reinh...@one.net>
Subject os-windows/1930: Related to PR1910 - Module Rewrite does not load
Date Tue, 10 Mar 1998 07:15:37 GMT

>Number:         1930
>Category:       os-windows
>Synopsis:       Related to PR1910 - Module Rewrite does not load
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Mon Mar  9 23:20:00 PST 1998
>Last-Modified:
>Originator:     reinhajh@one.net
>Organization:
apache
>Release:        1.3b3 and 1.3b5
>Environment:
Windows NT 4.0 SP3, VC++ V5.0, Pentium 90, 128MB
>Description:
Using the LoadModule directive, you cannot get the ReWrite module to load.
Apache returns an error stating that the module cannot be found in file
XXX/ApacheModuleReWrite.DLL
>How-To-Repeat:
Easily.  Just try to load the module.
>Fix:
The module declaration in the source file mod_rewrite.c needs to change
from:
    module rewrite_module = {
to:
    module MODULE_VAR_EXPORT rewrite_module = {
           ^^^^^^^^^^^^^^^^^ this is missing.
           
I changed my copy and rebuilt the DLL and it loads and works fine
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message