www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Falk W.Mueller <fwm...@fwm.net>
Subject mod_cgi/1920: CGIs don't run: Error_log says "Couldn't spawn new child process"
Date Sat, 07 Mar 1998 08:05:38 GMT

>Number:         1920
>Category:       mod_cgi
>Synopsis:       CGIs don't run: Error_log says "Couldn't spawn new child process"
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Sat Mar  7 00:10:01 PST 1998
>Last-Modified:
>Originator:     fwmone@fwm.net
>Organization:
apache
>Release:        1.3b3 and 1.2.5
>Environment:
Linux alpha 2.0.33 #3 i586. Compiler: gcc
>Description:
If I start a cgi-script on my server, it only returns "500 Internal Server Error". A view
into the error_log of 1.3b3 says following: [error](24)Too many open files: couldn't spawn
child process: /home/cgi-bin/hidecounter.pl. 1.2.5 says the same.

I don't know what to do, all scripts ran before on the same server! User wwwrun has access
to the files, I've increased the filedescriptors to 8196 (!).

Please help me!
>How-To-Repeat:
http://fwm-counter.com/cgi-bin/hidecounter.pl
http://fwm-counter.com/cgi-bin/showlog.pl
>Fix:
??%3
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message