www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: os-linux/1893: Server halts for apparently no reason
Date Mon, 02 Mar 1998 02:10:01 GMT
The following reply was made to PR os-linux/1893; it has been noted by GNATS.

From: Dean Gaudet <dgaudet@arctic.org>
To: ROOT <root@wipd.com>
Cc: apbugs@apache.org
Subject: Re: os-linux/1893: Server halts for apparently no reason
Date: Sun, 1 Mar 1998 18:01:46 -0800 (PST)

 nice +19 *shouldn't* cause this problem to happen... and the ethernet card
 changes shouldn't cause it to happen either.  The motherboard swap may be
 the blame though.  Have you stressed the new motherboard with, say, a full
 kernel compile but with lots of processes?  Like: 
 
     make -j7 MAKE='make -j7'
 
 I find this will show motherboard and memory problems pretty quickly. 
 
 But in this case I'm thinking the nice +19 may be more likely the blame. 
 But I can't imagine how it'd be the cause... lemme see if I can reproduce
 it. 
 
 Dean
 
 On Sun, 1 Mar 1998, ROOT wrote:
 
 > Yes, it was running fine yesterday.  Some major changes I made:
 > 
 > Swapped motherboards (hehe, not something you do everyday)
 > Made all daemons run with nice +19
 > Swapped ethernet card places, so arp address is different
 > 
 > I believe running everything with +19 priority was very bad.  It has run
 > for over an hour just fine since I now run everything with +0 priority.  I
 > set everything to +19 because I thought that would make the server less
 > able to crash, but I don't really know if that helps.
 > 
 > On Sun, 1 Mar 1998, Dean Gaudet wrote:
 > 
 > > 
 > > 
 > > On Sun, 1 Mar 1998, ROOT wrote:
 > > 
 > > > Apache has run fine with this setup until today.  I don't believe that
 > > > that would be the problem.
 > > 
 > > Your original problem report made it sound like you've been having this
 > > trouble for a while.  If it just started today then you should be able to
 > > isolate the differences between yesterday and today. 
 > > 
 > > Presumably you've been adding vhosts now and then... and each vhost you
 > > add increases the number of descriptors by 2.  If there are problems with
 > > your libc they may not show up until you reach a certain number of vhosts.
 > > 
 > > Dean
 > > 
 > 
 > 
 

Mime
View raw message