www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugene Crosser <cros...@average.org>
Subject Re: os-solaris/1190: server processes in keepalive state do not die after keepalive-timeout
Date Sat, 20 Dec 1997 11:20:00 GMT
The following reply was made to PR os-solaris/1190; it has been noted by GNATS.

From: Eugene Crosser <crosser@average.org>
To: Dean Gaudet <dgaudet@arctic.org>
Cc: apbugs@apache.org
Subject: Re: os-solaris/1190: server processes in keepalive state do not die after keepalive-timeout
Date: Sat, 20 Dec 1997 11:37:49 +0300 (MSK)

 > But 1300 hits/*day* is barely any load at all.  That's why I'm asking what
 > the real number is. 
 
 Oh, yes, you are right!  Probably it really was 13,000/day.
 And approximately one request of 2000 was causing a lethargic process.
 
 Anyway, from the first try, 1.3b3 does *not* have the reported problem:
 
 Current Time: Sat Dec 20 11:10:01 1997 
 Restart Time: Fri Dec 19 21:52:17 1997 
 Server uptime: 13 hours 17 minutes 44 seconds
 Total accesses: 14386 - Total Traffic: 13.8 MB
 CPU Usage: u0.75 s1.18 cu0 cs0 - 0.00403% CPU load
 0.301 requests/sec - 302 B/second - 1005 B/request
 1 requests currently being processed, 9 idle servers 
 
 and there are no sleeping keepalive processes.  Of course I need to
 run it more and watch.
 
 If things go wrong I will report it but for now it seems that the new
 version has cured my problem.  (Bad news is that there is no SSL patch
 for 1.3 yet, but you cannot have everything ;)
 
 Thanks you all for your assistance, and for an excellent www server.
 
 Eugene

Mime
View raw message