www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Beck <jb...@connectnet.com>
Subject config/1580: Configure doesn't generate appropriate Makefiles when using mod_auth_dbm
Date Sat, 20 Dec 1997 00:53:43 GMT

>Number:         1580
>Category:       config
>Synopsis:       Configure doesn't generate appropriate Makefiles when using mod_auth_dbm
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Dec 19 17:00:00 PST 1997
>Last-Modified:
>Originator:     jbeck@connectnet.com
>Organization:
apache
>Release:        1.2.4
>Environment:
All Versions of RedHat Linux from 4.0 - 5.0, possibly earlier versions.
>Description:
For Redhat 4.X, The Configure script generates an incorrect LIBS1= line when
you are using mod_auth_dbm
It should read LIBS1= -ldb, not LIBS1= -ldbm

For Redhat 5.X, The line still reads LIBS1 = -ldb, when to generate a working
binary it should read:
LIBS1 = -lgdbm -lcrypt
>How-To-Repeat:
Try to compile with default Makefile after enabling mod_auth_dbm in
Configuration file
>Fix:
Fix Configure/Configuration.. I haven't cared to look into it
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message