www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Richard Goerwitz <Richard_Goerw...@Brown.EDU>
Subject mod_proxy/1578: http://www.stg.brown.edu/homehead.gif won't load via ProxyPass with SSL
Date Fri, 19 Dec 1997 22:35:11 GMT

>Number:         1578
>Category:       mod_proxy
>Synopsis:       http://www.stg.brown.edu/homehead.gif won't load via ProxyPass with SSL
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Dec 19 14:40:00 PST 1997
>Last-Modified:
>Originator:     Richard_Goerwitz@Brown.EDU
>Organization:
apache
>Release:        1.2.4 + SSL patches
>Environment:
Linux (kernel 2.0.32, RedHat 4.2); gcc 2.7.2
>Description:
ProxyPass works beautifully for me.  Or at least it did until starting working
with a page that contained a specific image:

  http://www.stg.brown.edu/homehead.gif
>How-To-Repeat:
Just add a pass-through proxy server to httpd.conf:

  Listen 1442
  <VirtualHost your.host.name:1442>
  ...
  ProxyPass / http://www.stg.brown.edu/
  </VirtualHost>

Then attempt to fetch:

  http://your.host.name:1442/homehead.gif

I cannot reproduce this problem with Apache, as distributed by RedHat.  I'm
only getting the problem with Apache-1.2.4 plus Ben's SSL patches, compiled
on a RedHat Linux 4.2 (+ gcc 2.7.2) system, with a few extra modules compiled
in (pam, db_auth, info; EXTRA_LIBS=-ldb -lpam -lpwdb -ldl).
>Fix:
I have no clue yet.  It took me hours of debugging just to figure out that
this image was the problem.
%0
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message