www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Trickett <trick...@pacbell.net>
Subject os-windows/1488: Can't get Perl to work
Date Thu, 27 Nov 1997 01:15:13 GMT

>Number:         1488
>Category:       os-windows
>Synopsis:       Can't get Perl to work
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          doc-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Nov 26 17:20:00 PST 1997
>Last-Modified:
>Originator:     trickett@pacbell.net
>Organization:
apache
>Release:        1.3b3
>Environment:
WindowsNT4.0/SP3
Perl (Win32) 5.003_07 Build 313
>Description:
I can't get Perl to work on my system. It works fine under my
other server (HTTPs). All I get with Apache is an error message.

couldn't spawn child process: d:/http/scripts/foo.bar

It's in a folder that Apache knows is full of cgi scripts, it know to
execute them, but nothing happens.

I know the scripts are okay, 'cos they work with my other HTTP server.

The snag is most if not all the documentation is Unix based, and doesn't
help as much to us NT types. So when ever I look at a FAQ there is no
support, or options.
>How-To-Repeat:
Can you get Perl to run. I think everything is configured correctly,
but it don't work.

For example  http://www.darwin.ucr.edu/scripts/detect.pl

works fine if I have HTTPs running, but won't work with Apache.
>Fix:
Improve NT documentation a bit.... Remember most NT users (including me) are
use to a .exe file not source code. I want to use Apache my current server
is slow, and can't do a lot of the stuff Apache will be able to do. We need
help files.... plain text will do....
>Audit-Trail:
>Unformatted:
[In order for any reply to be added to the PR database, ]
[you need to include <apbugs@Apache.Org> in the Cc line ]
[and leave the subject line UNCHANGED.  This is not done]
[automatically because of the potential for mail loops. ]




Mime
View raw message