www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nasser Abbasi <nabb...@earthlink.net>
Subject general/1257: Apache crashes when passing argument to cgi program
Date Sun, 19 Oct 1997 13:41:23 GMT

>Number:         1257
>Category:       general
>Synopsis:       Apache crashes when passing argument to cgi program
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Sun Oct 19 06:50:00 PDT 1997
>Last-Modified:
>Originator:     nabbasi@earthlink.net
>Organization:
apache
>Release:        1.3b2
>Environment:
NT 4.0 , service 3
VC++ 5.0
>Description:
When I open url to my cgi program, and pass it an argument like this:

http://nasser.machine.com/cgi-bin/my_program?argument

Apaches encounters an access violation: Unhandled execption in Apache.exe
(APACHECORE.DLL).

without an argument to the cgi program, it work, adding a "?argument" crashes
apaches.  I tested my cgi program on another server with argument and
it works ok, only on Apache 1.3b2 it crahses the server.
>How-To-Repeat:
simply write the most simple cgi program, put it in cgi-bin/ directory,
and issue the URL for it but add a 

?anything_here

after the name of the cgi program.
>Fix:
No, I tried to build apaches 1.3b2 in debug , but your Makefile.nt is broke,
I can not build the tartget _apached , to build it in debug. I was trying
to debug this myself to help
>Audit-Trail:
>Unformatted:


Mime
View raw message