www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JDC <yo...@parodius.com>
Subject Re: general/1247: Main server configuration & VirtualHosts are botched
Date Sun, 19 Oct 1997 06:27:51 GMT
> Synopsis: Main server configuration & VirtualHosts are botched
> 
> State-Changed-From-To: open-analyzed
> State-Changed-By: marc
> State-Changed-When: Sat Oct 18 22:57:34 PDT 1997
> State-Changed-Why:
> It is quite unfortunate that you do not find pleasure in
> using Apache.
> 
> Did Ken's NameVirtualHost suggestion help?  You just need
> one for each IP you want to be considered for name-based
> vhost matching, not one before each VirtualHost section
> as he implied.

	I've tried this implementation as well, placing lines
	suc has the following into the httpd.conf:

	<VirtualHost virtualhost.parodius.com>
	NameVirtualHost 206.190.135.249:80
	User user
	Group group
	ServerName virtualhost.parodius.com
	</VirtualHost>

	This results in the VirtualHost's working, but the main
	server configuration not working -- the main server
	then goes to the first <VirtualHost> defined, despite
	not containing the same name (but the same IP).

> Where are you testing this from?  If your client is running
> on the same box as the server, there are known issues.  Try
> a client running on a seperate machine.

	My Client is Netscape Communicator 4.03 for Windows 95.
	It is running on my Windows 95 box, on a network com-
	pletly outside of where the server is.

	Again, this is not the problem -- once I reverted back
	to 1.3a1 or 1.2.4, the problem went away.

--
| Jeremy Chadwick                                        yoshi@parodius.com |
| System/Network/Security Administrator                  yoshi@dnc.net      |
| http://yoshi.parodius.com/                        "OUCH! WHAT DO YOU DO?" |


Mime
View raw message