www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Wikne <wi...@lynx.uio.no>
Subject general/1119: Some transfers to distant sites terminate with graphics incomplete.
Date Thu, 11 Sep 1997 18:40:03 GMT

>Number:         1119
>Category:       general
>Synopsis:       Some transfers to distant sites terminate with graphics incomplete.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Sep 11 11:40:02 1997
>Originator:     wikne@lynx.uio.no
>Organization:
apache
>Release:        1.2.*
>Environment:
Solaris 2.5 and 2.5.1
Problem occurs using both gcc and original Sun C.
>Description:
Since upgrading from 1.1.1 to 1.2.* (including betas and now 1.2.4) there has been
an obscure problem on three different Suns we have running Solaris 2.5 and 2.5.1.
Symptoms are that some transfers, especially to distant sites, terminate with
in-line graphics or other page elements incompletely transferred.
Sometimes, but not always, the error log contains messages of type "Broken pipe"
that seem correlated with this behaviour. I have not found anything in the
documentation on what this message implies.
The problem is _not_ present when we downgrade to 1.1.1, and _not_ on a Linux
2.0.27 system with Apache 1.2.*. Also, on Linux the "Broken pipe" messages
are absent.
>How-To-Repeat:
An example page that exhibits the problem is http://cheetah.uio.no/csg/spa-ssas.htm
It is only reproducable (it would appear) from distant clients with long download
times.
A jpeg screen capture of what the problem appears as is given by
http://lynx.uio.no/jon/gif/misc/cheetah1.jpg
Note that the circular animal icons are cropped at the bottom.
>Fix:
No. I haven't dug into the source code. Experiments with the KeepAliveTimeout
and Timeout directives have failed
>Audit-Trail:
>Unformatted:



Mime
View raw message