www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonas Öberg <jo...@coyote.org>
Subject mod_cgi/999: When executing a specific cgi-script a second time, the server experiences an internal error.
Date Fri, 15 Aug 1997 19:10:01 GMT

>Number:         999
>Category:       mod_cgi
>Synopsis:       When executing a specific cgi-script a second time, the server experiences
an internal error.
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Aug 15 12:10:01 1997
>Originator:     jonas@coyote.org
>Organization:
apache
>Release:        1.1.2 and 1.2.1
>Environment:
Uname -a: Linux poledra 2.0.30 #11 Fri May 30 17:44:03 MET DST 1997 i486 unknown
gcc version 2.7.2.1, libc 5.4.33, 80 Mb RAM, standard equipment
>Description:
I have a small CGI-program that does nothing more then display the user with a dialog box
and upon receiving information places that information in a file (appended) and then displays
the dialog box again. When executed, the script displays the box a first time but when submiting
information (via POST), the server experiences an internal error, thus returning an errormessage.
If I start httpd on a virtual terminal, I can see on stderr that the server outputs "Ouch!
 malloc failed in malloc_block()". Other cgi-scripts works perfectly well.
>How-To-Repeat:
Unless I have fixed it, the script is on http://poledra.coyote.org:8080/mush/send.cgi and
expects a variable as a command-line argument, thus: <URL:http://poledra.coyote.org:8080/mush/send.cgi?2>.
>Fix:

>Audit-Trail:
>Unformatted:



Mime
View raw message