www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Long <ml...@infoave.net>
Subject config/919: scriptalias doesnt work for multiple servernames
Date Sat, 26 Jul 1997 00:00:02 GMT

>Number:         919
>Category:       config
>Synopsis:       scriptalias doesnt work for multiple servernames
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Jul 25 17:00:01 1997
>Originator:     mlong@infoave.net
>Organization:
apache
>Release:        1.2
>Environment:
redhat linux 4.2

Linux defiant.questgate.net 2.0.30 #1 Tue Apr 22 10:49:45 EDT 1997 i586 unknown

>Description:
With Apache 1.2, you can use multiple servernames in a virtual host.  The problem is, the
script alias does not work for anything but the last servername.  IE in my setup I have in
httpd.conf (redirect, log, etc. not listed below):



<VirtualHost defiant.questgate.net>

DocumentRoot /home/httpd/https-defiant/docs

ServerName defiant.questgate.net

ServerName questgate.net

ServerName questgate.com

ServerName www.questgate.com

ServerName defiant.questgate.com

ServerName www.questgate.net

ScriptAlias /dcgi/ /home/httpd/https-defiant/docs/cgi-bin/



now when i go to www.questgate.net/dcgi/ i can use the cgi;s

if i go to like www.questgate.com/dcgi/, it says file not found...but all the web pages, etc.
come up...just cant use script alias
>How-To-Repeat:
www.questgate.net - the top banner is an included cgi

questgate.com - same, but the top doesnt work

>Fix:

>Audit-Trail:
>Unformatted:



Mime
View raw message