www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raymond Leach <rle...@qdn.qdata.co.za>
Subject config/910: My additional ScriptAlias does not work in the srm.conf file.
Date Thu, 24 Jul 1997 16:30:02 GMT

>Number:         910
>Category:       config
>Synopsis:       My additional ScriptAlias does not work in the srm.conf file.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Jul 24 09:30:02 1997
>Originator:     rleach@qdn.qdata.co.za
>Organization:
apache
>Release:        1.2.1
>Environment:
uname -a = SunOS centera-ars 5.4 Generic_101945-38 sun4d sparc

SunSparc 1000E 512MB RAM, 12GB Disk, 4x85MHz processors.

Precompiled binary from Internet Solutions.
>Description:
No core dumps or errors. When I attempt to run a script (arweb) from my new ScriptAlias directory,
all I get is the script content, as if the server was reading a text file. I have checked
the config files and I have specified the following:

In srm.conf
Alias /icons/ /data/httpd/icons/
Alias /ars /usr1/ar/arweb/data

# ScriptAlias: This controls which directories contain server scripts.
# Format: ScriptAlias fakename realname

ScriptAlias /cgi-bin/ /data/httpd/cgi-bin/
ScriptAlias /ars/cgi-bin /usr1/ar/arweb/cgi-bin


In access.conf

<Directory /usr1/ar/arweb/cgi-bin>
Options ExecCGI
</Directory>

If I move the arweb script to the default cgi-bin directory, it executes correctly.
Also my Alias to /ars woks correctly.
>How-To-Repeat:
Test as above?
>Fix:

>Audit-Trail:
>Unformatted:



Mime
View raw message