www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vermont Rutherfoord <verm...@gate.net>
Subject general/885: After a period of time (not found to coincide with server rehashes or any specific access), the server will read requests, but return no data (and close the connection). It will still respond to a server-status request though.
Date Fri, 18 Jul 1997 18:40:02 GMT

>Number:         885
>Category:       general
>Synopsis:       After a period of time (not found to coincide with server rehashes or
any specific access), the server will read requests, but return no data (and close the connection).
 It will still respond to a server-status request though.
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri Jul 18 11:40:01 1997
>Originator:     vermont@gate.net
>Organization:
apache
>Release:        1.2.1
>Environment:
Linux pandora 2.0.29-ISS #18 Tue Apr 1 07:25:28 EST 1997 i686.1
gcc v2.7.2.1

Apache is patched with the MS FrontPage WPP Apache patch which allows wildcards in scriptaliases
>Description:
What shows up in the errorlog after the problem starts:
[Fri Jul 18 12:09:06 1997] send body lost connection to client 153.34.100.77
[Fri Jul 18 12:09:16 1997] request lost connection to client 206.64.135.50
[Fri Jul 18 12:09:16 1997] request lost connection to client 194.128.172.1
[Fri Jul 18 12:09:16 1997] request lost connection to client 208.210.104.80
[Fri Jul 18 12:09:16 1997] request lost connection to client 207.120.46.120
[Fri Jul 18 12:09:17 1997] request lost connection to client 206.64.135.50
[Fri Jul 18 12:09:17 1997] request lost connection to client 202.154.44.238
[Fri Jul 18 12:09:18 1997] request lost connection to client 203.231.242.62
[Fri Jul 18 12:09:18 1997] request lost connection to client 193.189.182.243
[Fri Jul 18 12:09:19 1997] request lost connection to client 203.2.193.69
[Fri Jul 18 12:09:19 1997] request lost connection to client 203.2.193.69
[Fri Jul 18 12:09:19 1997] request lost connection to client 207.142.161.36
[Fri Jul 18 12:09:19 1997] request lost connection to client 203.2.193.69
[Fri Jul 18 12:09:19 1997] request lost connection to client 152.163.204.7
[Fri Jul 18 12:09:19 1997] request lost connection to client 203.2.193.69
[Fri Jul 18 12:09:19 1997] request lost connection to client 152.163.204.7

There are still occasional errors about clients requesting nonexistant files (normal).
Unknown if the client receives a response in those cases..
Haven't thought to test this yet, but the next time it happens I will.
I currently don't know what triggers the bug, but it usually happens after the server has
been up for a few days without interruption.
This has happened at least 3 times on one server that has 807 virtualhosts,
and about the same number of times on a server that has 207 virtualhosts (and increasing).

I upgraded from 1.2b11 and never saw this happen with that version.

Top part of server status I grabbed from a server that was returning empty responses:
   Current Time: Fri Jul 18 12:32:20 1997
   Restart Time: Tue Jul 15 15:09:09 1997
   Server uptime: 2 days 21 hours 23 minutes 11 seconds
   Total accesses: 428419 - Total Traffic: 4.0 GB
   CPU Usage: u2.37 s2.74 cu27.93 cs2.86 - 0.0144% CPU load
   1.72 requests/sec - 16.7 kB/second - 9.7 kB/request
   6 requests currently being processed, 6 idle servers
W__WR_W_W_....R_................................................
................................................................
................................................................
................................................................
>How-To-Repeat:
No idea
>Fix:
I will see if I find anything while looking through source code... 
But no idea at the moment
>Audit-Trail:
>Unformatted:



Mime
View raw message