www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Harris <dhar...@drh.net>
Subject general/852: Apache complains at not resolving a domain name which exists.
Date Thu, 10 Jul 1997 17:10:02 GMT

>Number:         852
>Category:       general
>Synopsis:       Apache complains at not resolving a domain name which exists.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu Jul 10 10:10:01 1997
>Originator:     dharris@drh.net
>Organization:
apache
>Release:        1.2.1
>Environment:
sunflo:/opt/AGapache/logs## uname -a
SunOS sunflo 5.5 Generic sun4c sparc SUNW,Sun_4_50
>Description:
I have a server which runs with (currently) no virtual hosts. I specify the bind address with
the fully qualified domain name (on my LAN) I have given my server. This domain name is not
internet accessible because it is on my LAN. I have the host setup to be the root, top level
domain, and second level domain dns server.

Here is the bind address config:

httpd.conf excerpt:
-----
BindAddress www.drh.tld.
-----

Here is a lookup of that domain name showing that it does exist:

-----
sunflo:/opt/AGapache/logs## dig www.drh.tld.

; <<>> DiG 2.0 <<>> www.drh.tld. 
;; ->>HEADER<<- opcode: QUERY , status: NOERROR, id: 6
;; flags: qr aa rd ra ; Ques: 1, Ans: 1, Auth: 0, Addit: 0
;; QUESTIONS: 
;;      www.drh.tld, type = A, class = IN

;; ANSWERS:
www.drh.tld.    86400   A       192.168.0.4

;; Sent 1 pkts, answer found in time: 2 msec 
;; FROM: sunflo to SERVER: default -- 192.168.0.4
;; WHEN: Thu Jul 10 12:52:47 1997
;; MSG SIZE  sent: 29  rcvd: 45
-----

Or nslookup if you prefer:

-----

sunflo:/opt/AGapache/logs## nslookup www.drh.tld.
Server:  sunflo.drh.tld
Address:  192.168.0.4

Name:    www.drh.tld
Address:  192.168.0.4
-----

And when I try to start the server it says:

-----
sunflo:/opt/AGapache/src## ./httpd -f /opt/AGapache/conf/httpd.conf
Cannot resolve host name www.drh.tld. --- exiting!
-----

So, I go ahead and give it the IP as the server address and then it does not die at that directive.
Instead it finds trouble with the ServerName directive which I have set to be "www.drh.tld."

httpd.conf excerpt:
-----
ServerName www.drh.tld.
-----

Here is how it complains. It looks like the server starts up and then dies because that other
prompt came up.

-----
sunflo:/opt/AGapache/src## ./httpd -f /opt/AGapache/conf/httpd.conf
sunflo:/opt/AGapache/src## httpd: cannot determine the IP address of the specified ServerName
(www.drh.tld.).
-----

If I then change the ServerName to be the IP, the server starts up fine. But, it looks like
it is not doing reverse DNS queries even though I told it to.

Weird.
>How-To-Repeat:
I don't know. If you want access to my system through telnet, I'll give it to you.
>Fix:
No idea
>Audit-Trail:
>Unformatted:



Mime
View raw message