www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Kurz <n...@tripod.com>
Subject general/843: StartServers directive works but children immediately die
Date Tue, 08 Jul 1997 22:40:02 GMT

>Number:         843
>Category:       general
>Synopsis:       StartServers directive works but children immediately die
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Tue Jul  8 15:40:01 1997
>Originator:     nate@tripod.com
>Organization:
apache
>Release:        1.2b7
>Environment:
SunOS triage 5.5.1 Generic_103640-08 sun4u sparc SUNW,Ultra-1
>Description:
I'm having problems getting StartServers to start any large number (> 100)
of children.  standalone_main() seems to start the correct number of 
children, but they immediately die off before they get out of
SERVER_STARTING.   

It's possible that this isn't really a bug, but since the children are
started after this one at a time (and once per second) it can several 
minutes until the machine levels off again.
>How-To-Repeat:
Kill and restart httpd on a heavily trafficked machine, and observe the 
number of processes running.
>Fix:
Perhaps change child_main so that the child does not exit until it has
served at least one request?  

Or change the make_child check in standalone_main into a while loop?
If you are running short of servers you probably want to get back to the
correct number faster than it is currently done.
%0
>Audit-Trail:
>Unformatted:



Mime
View raw message