www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: general/726: keep-alive in 1.2 released vs. 1.2 beta(s)
Date Thu, 12 Jun 1997 18:38:07 GMT
It's definately HTTP/1.1 keepalive, including support for pipelining
clients.  In between 1.2b5 and b6 (or maybe b7) there changes which
eliminated extra packet flushes after the headers were sent.  By b8 we had
to fix a bug with POSTs.  Then in b9 we added support to hack around a bug
in netscape navigator (it screws up if the headers end on the 257th or
258th byte of a packet).

My guess is that your buffering code has a bug in it... the best thing to
do at this point is to "tcpdump -s 1576 -o outfile tcp port 80 and host
my.client.hostname".  Then use tcpshow
<http://www.cs.berkeley.edu/~daw/mike/> to look at what apache sent.  I'm
sure you'll find we sent all the right stuff ... I went through all of
this analysis at the beginning of the year when we had a bug report from
the w3c regarding http/1.1 keepalive. 

But if you can get a dump that shows we screwed up, please send it! 

Dean

On Thu, 12 Jun 1997, D. J. Hawkey Jr. wrote:

> 
> >Number:         726
> >Category:       general
> >Synopsis:       keep-alive in 1.2 released vs. 1.2 beta(s)
> >Confidential:   no
> >Severity:       non-critical
> >Priority:       medium
> >Responsible:    apache (Apache HTTP Project)
> >State:          open
> >Class:          sw-bug
> >Submitter-Id:   apache
> >Arrival-Date:   Thu Jun 12 10:10:01 1997
> >Originator:     hawkeyd@visi.com
> >Organization:
> apache
> >Release:        1.2beta(s)
> >Environment:
> QNX 2 G 423 PCI 32
> >Description:
> Please don't yell at me, as this isn't relavent to the latest release,
> which doesn't exhibit the problem.
> 
> I'm implementing HTTP/1.1 persistant connections in Chimera-1.70, and when
> hitting on Apache-1.2 [with it], everything goes well. When hitting on sites
> using Apache-1.2bNN [with it], things go awry where inline images are
> concerned. I can document responses from the betas that have no header.
> 
> Even though Apache-1.2bNN responds "HTTP/1.1", is the keep-alive technology
> still HTTP/1.0?
> >How-To-Repeat:
> Get my test code of Chimera-1.70, and hit on your Web site, or www.qnx.com.
> 
> Please don't! I'm just being facetious.
> A simple reply will be more than sufficient.
> >Fix:
> 
> >Audit-Trail:
> >Unformatted:
> 
> 
> 


Mime
View raw message