www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randal Lathrop <randal_lath...@mech.disa.mil>
Subject os-solaris/585: .htaccess files are ignored by Apache on Solaris 2.3 machine
Date Thu, 15 May 1997 20:50:01 GMT

>Number:         585
>Category:       os-solaris
>Synopsis:       .htaccess files are ignored by Apache on Solaris 2.3 machine
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Thu May 15 13:50:01 1997
>Originator:     randal_lathrop@mech.disa.mil
>Organization:
apache
>Release:        1.2b7
>Environment:
SunOS ns2 5.3 Generic_101674-01 sun4m sparc
>Description:
On a Solaris 2.3 machine running Apache 1.2b7, .htaccess files in directories
to be protected are being ignored and full access is being granted to anybody.

To verify that my .htaccess file is correct, I tried it on an RS-6000/320
machine running Apache 1.2b7 and it worked fine.
>How-To-Repeat:
Here is the .htaccess file from /usr/local/wwwroot/mrtg in question:

Options Indexes
AllowOverride None
AuthUserFile /usr/local/apache/conf/.htpasswd
AuthGroupFile /dev/null
AuthName
AuthType Basic

<Limit GET>
require user xth0009
</Limit>

When this file is inserted into access.conf with the <DIRECTORY> </DIRECTORY>
tags inserted, it works fine (only if .htaccess is not in the directory listed.)
If .htaccess is in the specified directory, an error message is returned.
>Fix:
Add the contents of the .htaccess files to access.conf.  But this defeats the
purpose of having .htaccecs files
>Audit-Trail:
>Unformatted:



Mime
View raw message