www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Livingston <eric_livings...@mail.amsinc.com>
Subject os-linux/564: 1.2b10 Stopped working after a kernel recompile, but 1.1.3 still works fine
Date Fri, 09 May 1997 15:20:01 GMT

>Number:         564
>Category:       os-linux
>Synopsis:       1.2b10 Stopped working after a kernel recompile, but 1.1.3 still works
fine
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Fri May  9 08:20:00 1997
>Originator:     eric_livingston@mail.amsinc.com
>Organization:
apache
>Release:        1.2b10
>Environment:
I'm running Linux, from the Redhat 4.1 release, kernel 2.0.27 on a 486
gcc version 2.7.2.1
>Description:
This may simply have to do with Kernel compile dependencies.  Both 1.1.3
and 1.2b10 worked fine under the production release of RedHat Linux 4.1.
However, I've recently recompiled my kernel (with no code modifications), and
now 1.2b10 won't accept a connection on port 80 (from a browser or even from
telnet - it just returns "connection refused". 1.1.3 continues to work.  I've
tested every program I can think of (ftp, telnet, rexec, mail, ping, finger,
etc.) from another station, and Linux is answering them all just fine.

This kernel compile is heavily modulerized (I've put everything I can into
modules).  The basic question is: does 1.2b10 require some kind of kernel
configuration that 1.1.3 does not require?

P.S. - 1.2b10 seems to load just fine.  The error_log reports a successful
start to 'normal operations'.  the access_log reports nothing - not even
failed connection attempts.  The daemon(s) are reported by ps, it's just as
though they are simply ignoring port 80. (and yes, the config file does point
it to port 80 - the config file is the same as I used before the kernel compile,
and it worked well)
>How-To-Repeat:

>Fix:
I assume I simply need to re-configure my kernel compile, but I'm stumped as to
how.  I've enabled every option I can think of, and thrown in all functionality
but the kitchen sink, and it still just wont respond..
>Audit-Trail:
>Unformatted:



Mime
View raw message