www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dean Gaudet <dgau...@arctic.org>
Subject Re: Changed information for PR os-irix/335
Date Wed, 09 Apr 1997 11:23:45 GMT
The SIGPIPE thing is a "known bug" that a few of us have noticed... in
fact we just talked about it tonight at the BOF.  I'm likely to try to
take Sameer's CGI buffering patch and produce something that'll work for
1.2.1.  (Which would actually nail both of these problems.)

Dean

On Wed, 9 Apr 1997 coar@decus.org wrote:

> Synopsis: cgi-bin script not receiving SIGPIPE during output if client hits STOP
> 
> State-Changed-From-To: open-feedback
> State-Changed-By: coar@decus.org
> State-Changed-When: Wed Apr  9 03:15:37 PDT 1997
> State-Changed-Why:
> Leaving the SIGPIPE part alone for the moment..  Apache
> buffers script output internally, which may be part of
> the problem.  Try renaming your script so the filename
> begins with "nph-" (e.g., to "nph-test.cgi") and try
> again.  The output from nph scripts does *not* get
> buffered.  Also, you can avoid the repeated flush() calls
> by simply putting "$| = 1;" before the first printf();
> this tells Perl not to buffer *its* output.  Please see
> if these changes have any effect, and we'll come back to
> the SIGPIPE issue.
> Category-Changed-From-To: os-irix-mod_cgi
> Category-Changed-By: coar@decus.org
> Category-Changed-When: Wed Apr  9 03:15:37 PDT 1997
> 
> 
> 


Mime
View raw message