www-apache-bugdb mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pascalis Samaras <psama...@the.unisoft.gr>
Subject general/461: More detailed description of problem 458 (TERM, HUP and KILL signals)
Date Wed, 23 Apr 1997 14:40:02 GMT

>Number:         461
>Category:       general
>Synopsis:       More detailed description of problem  458 (TERM, HUP and KILL signals)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    apache (Apache HTTP Project)
>State:          open
>Class:          sw-bug
>Submitter-Id:   apache
>Arrival-Date:   Wed Apr 23 07:40:01 1997
>Originator:     psamaras@the.unisoft.gr
>Organization:
apache
>Release:        1.2b8
>Environment:
SCO Unixware 2.03 on Pentium CPU.
Compiler options -O -Kblended
>Description:
When I stop the httpd ( kill -TERM pid ) I can not  restart it and the following messages
appear

bind: Address already in use
httpd: could not bind to port xxx.

netstat -an reports than port is in LISTEN state.

When I send a KILL signal the behavior is similar to TERM but child processes 
are not killed (some of them) and they do not respond to requests.

When I send a HUP signal to re-read the configuration (kill -HUP httpd.pid) the same messages
appear, the parent httpd process is killed, some child processes 
remain (but the do not respond to requests) and I connot kill them
(using kill -TERM or kill -KILL) 

The following are loged in error_log when HUP signal is send :

[Wed Apr 23 13:27:54 1997] child process 602 did not exit, sending another SIGHUP
[Wed Apr 23 13:27:58 1997] child process 602 still did not exit, sending a SIGTERM
[Wed Apr 23 13:28:03 1997] child process 602 still did not exit, sending a SIGKI
LL
[Wed Apr 23 13:28:07 1997] could not make child process 602 exit, attempting to
continue anyway
[Wed Apr 23 13:28:07 1997] SIGHUP received.  Attempting to restart

This problem looks relative with problems 253, 273, 303, 381.
>How-To-Repeat:
These problems repeat always.
>Fix:

>Audit-Trail:
>Unformatted:



Mime
View raw message